change the build system from 'foreign' to 'gnu' requirements